Registration Notice

Due to increased spam, forum registration must be manually approved by a moderator! Please see this post for instructions.

*

Offline Rongyos

  • 16
    • View Profile
  • Hungary
Compatible teensy versions
« on: July 09, 2022, 06:23:45 AM »
Hi fellow tankers.

My sound cards are under assembling and I have a teensy 2.0 at home. Will IT work perfectly or v3.2 is necessary?

Regards
Rongyos

*

Offline LukeZ

  • 1196
    • View Profile
  • France
Re: Compatible teensy versions
« Reply #1 on: July 09, 2022, 03:26:21 PM »
Hi Rongyos, unfortunately although the Teensy 2.0 can do many things, it does not have the necessary processing power to handle the sound generation. So you will need to use the Teensy 3.2.

I know right now they are not available due to the supply chain mess. The semi-conductor shortage is a real problem, much bigger than I thought it would be when it first started. It does not appear at all close to being resolved. When major car manufacturers in America can no longer make automobiles, I don't know how long it will be before hobby things like the Teensy will be able to return.
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

*

Offline Rongyos

  • 16
    • View Profile
  • Hungary
Re: Compatible teensy versions
« Reply #2 on: July 11, 2022, 06:25:59 AM »
Hi Rongyos, unfortunately although the Teensy 2.0 can do many things, it does not have the necessary processing power to handle the sound generation. So you will need to use the Teensy 3.2.

I know right now they are not available due to the supply chain mess. The semi-conductor shortage is a real problem, much bigger than I thought it would be when it first started. It does not appear at all close to being resolved. When major car manufacturers in America can no longer make automobiles, I don't know how long it will be before hobby things like the Teensy will be able to return.

Hi Luke!

Thanks for your fast reply. I try to not be annoying, but what about teensy 4.0? It is available at local stores.

Regards
Rongyos

edit: I found this comparison table. The 4.0 version has differenc processor, so I assume this is not compatible for the board but waiting for your confirmation.

*

Offline LukeZ

  • 1196
    • View Profile
  • France
Re: Compatible teensy versions
« Reply #3 on: July 11, 2022, 08:20:38 AM »
Hi Rongyos, your questions are not annoying at all!

In fact there are several other Teensy boards that could be made to work with the OP Sound Card firmware, but they would all require significant changes to the code and the physical circuit board. The 3.5/3.6 have nearly the same type of sound output as the 3.2, but they are a physically much larger and would require a complete board redesign. Also the 3.5/3.6 processors are unavailable right now the same as the 3.2, so that is no help.

The 4.0 can also produce sound, but it only outputs the sound digitally. This means that instead of the sound output going straight to an amplifier chip, it would first have to go to a digital-analog converter, and then the amplifier. So again a complete board redesign, and also changes to the firmware.

Unfortunately such a redesign is not something I have the time for. And I can't even say that if someone started on this undertaking there might not be other complications that could arise, as I have not explored in depth all the differences. Even if I had the time, I might be hesitant to take on such a project in the current environment, because who is to say that the 4.0 or other components (amplifers or who knows what) might also be affected by shortages in the near future.

I'm sorry I can't be of more help! But I hope that answers your question.
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

*

Offline Lotuswins

  • 160
    • View Profile
  • Roseburg, oregon
Re: Compatible teensy versions
« Reply #4 on: July 11, 2022, 09:55:01 PM »
Thanks for the tip Luke, just wish I'd checked sooner......I've got three 4.0 teenie's now that are no good to me...no wonder my sound cards wouldn't work!!  I think they loaded okay, just seemed to act a little wierd.  Now to find some 3.2 versions...maybe I'll get lucky :)

jerry

*

Offline NS-21

  • 48
  • dreamer
    • View Profile
  • Russia
Re: Compatible teensy versions
« Reply #5 on: July 13, 2022, 05:10:36 PM »
Thanks for the tip Luke, just wish I'd checked sooner......I've got three 4.0 teenie's now that are no good to me...no wonder my sound cards wouldn't work!!  I think they loaded okay, just seemed to act a little wierd.  Now to find some 3.2 versions...maybe I'll get lucky :)

jerry

I think I've been trying to get 3.2 versions for over a year...

Or a chip with a recorded bootloader. So far nothing has worked.

It's bad that I can't rewrite the program - to another platform.