Registration Notice

Due to increased spam, forum registration must be manually approved by a moderator! Please see this post for instructions.

*

Offline Lotuswins

  • 159
    • View Profile
  • Roseburg, oregon
Another Update Issue
« on: January 01, 2022, 10:32:36 PM »
Hi Luke,

Happy holidays to you and yours!!

So I just got a new laptop from Dell, with windows 11 on it and I'm having some issues with OP Config.  When I select 'Get Latest Release' I get a different hex file name each time, like TCBMK1_99-61-99.hex which is only 1kb in size.  The names vary in the numbers only, and of course, they won't flash since they apparently have little to no content. But if I select 'use your own hex', I can see the older versions and they will flash.  Also, I can download the latest hex manually and it will flash. 

Another oddity is that in the file manager, if I try to see what is in the folder where the hex files exist, they won't show unless I have manually downloaded it, but OP will show all that are there....

I guess windows 11 is a little different?? 

Anyways I got it working okay, but just wondering what is going on. 

Thanks,

Jerry

*

Offline LukeZ

  • 1156
    • View Profile
  • France
Re: Another Update Issue
« Reply #1 on: January 02, 2022, 07:03:27 AM »
Hi Jerry, thanks for letting me know about this. I've recently added SSL to the website and it seems to have broken quite a few things, including the ability of OP Config to download the files. It now has to use a different protocol which I hadn't originally programmed it to know anything about, so I need to correct that. 

As you've found the Hex files do still exist on the website and if you download them manually you can still use them with OP Config. I don't think there is anything wrong with your Windows 11 setup, the problem is on my end!

Anyway I am working on fixing this and I will post back when I've gotten it resolved.



Luke
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

*

Offline LukeZ

  • 1156
    • View Profile
  • France
Re: Another Update Issue
« Reply #2 on: January 02, 2022, 02:31:06 PM »
Hi Jerry,

I've posted an updated version of OP Config (v0.93.74). Would you be willing to update your version of OP Config and see if I've successfully fixed it?

In OP Config to go the Help menu and click on "Check for Updates" - or you can just download the new OP Config installer file from the Downloads page.

It's fixed for me but it would be good to have confirmation from someone else.
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

*

Offline Lotuswins

  • 159
    • View Profile
  • Roseburg, oregon
Re: Another Update Issue
« Reply #3 on: January 02, 2022, 03:15:16 PM »
Hi Luke, 

Boy, that was quick. 

Sorry to report that it is still selecting the 1kb size hex file, and it is still numbered oddly.  I also get a script on the screen saying:

Moved Permanently
The document has moved here.


and under the file name is:

Version: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//

if that helps?

Thanks for the continued support!!!

Jerry

*

Offline Lotuswins

  • 159
    • View Profile
  • Roseburg, oregon
Re: Another Update Issue
« Reply #4 on: January 02, 2022, 03:32:23 PM »
Hi again Luke,

So I did the download the executable , and it simply downloaded the old one apparently as the results were the same (as I noted above).  So I did the check for updates next, and it downloaded the new version.  Unfortunately now, when I select the 'get the latest', the OP program goes to the blue donut of 'thinking', and no longer responds, I have to go the the task manager to stop it.   

I'd like to give you a screen capture, but am unsure of the keystrokes as I don't do that often......

Hmmmm.......

Jerry

*

Offline LukeZ

  • 1156
    • View Profile
  • France
Re: Another Update Issue
« Reply #5 on: January 02, 2022, 03:39:39 PM »
Ok, I was just replying when you wrote, it did sound like originally it hadn't installed the new version. Almost certainly that was your browser trying to be "helpful" and serving you the cached copy of the program from the last time you'd downloaded it, instead of the new one that had overwritten it. But now you've gotten that part taken care of.

I too noticed that it is now much slower when checking for a new release, and I saw the little rotating blue circle thingy too. However in my case the blue circle finally went away after about 10 or 15 seconds or so.

I suppose you could let it sit there and keep thinking for a while and see how long it lasts. But really it shouldn't take long, the file we are downloading is very small. I think the SSL is really slowing it down.

I am really of half a mind to revert back to where I was to begin with, the website has been without an SSL for a decade and no one has died yet... This is the punishment I get for tinkering with stuff!
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

*

Offline LukeZ

  • 1156
    • View Profile
  • France
Re: Another Update Issue
« Reply #6 on: January 02, 2022, 04:21:09 PM »
I have a few more ideas of things I can do on this end. It's late on this side of the planet but I'll get back to it again tomorrow and let you know what I come up with.
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

*

Offline LukeZ

  • 1156
    • View Profile
  • France
Re: Another Update Issue
« Reply #7 on: January 03, 2022, 08:45:22 AM »
Hi Jerry, I've made a few more changes. I'll skip the boring details but the goal is to be able to use OP Config as it was without any modifications to that program. I've reverted back to the prior version of 0.93.73 unchanged from how it was, and it should now work again as normal.

You'll want to uninstall 0.93.74 and then download 0.93.73 and re-install. To prevent any issues with your browser serving you a cached file, download 0.93.73 from this page.

It seems to be working for me but let me know what happens on your end.
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

*

Offline Lotuswins

  • 159
    • View Profile
  • Roseburg, oregon
Re: Another Update Issue
« Reply #8 on: January 03, 2022, 06:10:41 PM »
Hi Luke,

So I just uninstalled 0.93.74 and reinstalled 0.93.73 as per your instructions (being careful to actually READ them .... lol), and all seems to be okay.  I downloaded the latest and installed it on a spare OPTCB and even installed some settings on it....so you fixed it, whew!!  So glad my new laptop is working with your wonderful program....

Thanks again!!  Jerry

*

Offline LukeZ

  • 1156
    • View Profile
  • France
Re: Another Update Issue
« Reply #9 on: January 04, 2022, 11:03:09 AM »
Thanks for reporting back Jerry! I'll try to avoid breaking things in the future. ;)
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

*

Offline Snipah

  • 18
  • As Real as Models can sound
    • View Profile
  • New Zealand
Re: Another Update Issue
« Reply #10 on: January 08, 2022, 04:09:34 PM »
Thats not the spirit Lukez, If you dont break something nothing ever improves :-)
Thats how enhancements get made

:-)

Happy New Year all
As Real as Models can sound

*

Offline LukeZ

  • 1156
    • View Profile
  • France
Re: Another Update Issue
« Reply #11 on: January 09, 2022, 12:50:45 PM »
Very true!  :D And happy New Year to you as well
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

 

bomber-explosion