Registration Notice

Due to increased spam, forum registration must be manually approved by a moderator! Please see this post for instructions.

*

Offline LukeZ

  • 1205
    • View Profile
  • France
Re: Benedini Mini problems
« Reply #15 on: September 02, 2019, 03:11:15 PM »
I see you are using TBS Flash v4.0. The most recent version I have is 3.0 so Thomas must have released an update recently. Possibly that is the problem. I will need to talk to him and see if anything has changed, and obtain the latest version so I can test it here. Give me a week or so to contact him and see what he says.

In the meantime if you have TBS Flash v3 you can try that.
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

*

Offline LukeZ

  • 1205
    • View Profile
  • France
Re: Benedini Mini problems
« Reply #16 on: September 02, 2019, 03:25:30 PM »
I have Benedini Mini v1 and got a problem.
When I want to upload the OP parameter it shows the pop-up message attached.
Looking more closely at your images, it appears you are trying to import the Open Panzer Prop Settings on the Parameter tab of TBS Flash. The Prop Settings must be loaded on the Diagnostic tab of TBS Flash (used to be called the Misc tab in Flash v3 and earlier).

There are no pre-configured Open Panzer parameter files for the Parameter tab, but you can create your own.

You might also want to run through Radio Setup in OP Config once more, and make sure you have all your channels assigned correctly. It's fine to have steering and throttle on the right stick (that is what I do), but during radio setup you just must make sure that when you move the throttle stick that OP Config shows it correctly assigned to throttle, and the same for steering, elevation and rotation.

Maybe you can also post your current OPZ file and I will take a look.

NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

*

Offline Rongyos

  • 22
    • View Profile
  • Hungary
Re: Benedini Mini problems
« Reply #17 on: September 02, 2019, 03:31:23 PM »
In the meantime if you have TBS Flash v3 you can try that.

Thank you Luke!

In the meantime can you check the log attached? I must be sure I not screwed up something.

Thank again!
*
KV1OP_bene.opz
(23.17 kB ~ Downloads: 200)

*

Offline LukeZ

  • 1205
    • View Profile
  • France
Re: Benedini Mini problems
« Reply #18 on: September 02, 2019, 03:50:08 PM »
Ok, I can see that your radio setup was not completed correctly. For example, for your throttle channel the min and max are set to 1500 and 1508. They should be something more like 1000 and 2000. The same is true for your other stick channels. This explains why you have no throttle response and why the turret stick functions are not working correctly.

Read again the Radio Setup and perform the radio setup routine once again.

Also I notice that you have functions to turn on and off the transmission when the engine turns on and off. This is not a problem but is unnecessary. When you start the engine the transmission is automatically engaged (after any Transmission Engage Delay setting from the Driving tab), and when you turn off the engine the transmission is automatically disengaged, you don't need any functions for that.

The reason there are functions for manually disengaging the transmission is that you could assign a switch to that, and then when your engine is running you can manually turn off the transmission. Now the model will not move but the engine sounds will still be running, smoker, etc... You can "rev" the throttle and hear all the sounds but your tank will stay stationary until you re-engage the transmission. But other than for that purpose, you don't need to use the transmission functions.

NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

*

Offline Rongyos

  • 22
    • View Profile
  • Hungary
Re: Benedini Mini problems
« Reply #19 on: September 03, 2019, 01:05:16 AM »
Hey Luke!

Thank you for your support!

Ok, I can see that your radio setup was not completed correctly. For example, for your throttle channel the min and max are set to 1500 and 1508. They should be something more like 1000 and 2000. The same is true for your other stick channels. This explains why you have no throttle response and why the turret stick functions are not working correctly.

Hmm... I managed the radio settings 2x, maybe I forgot to upload it to the board :/ I will do it at home again and report the result

Quote from: LukeZ
Looking more closely at your images, it appears you are trying to import the Open Panzer Prop Settings on the Parameter tab of TBS Flash. The Prop Settings must be loaded on the Diagnostic tab of TBS Flash (used to be called the Misc tab in Flash v3 and earlier).

The V4.0 flash is different, I think. There is no upload button on "Diagnostic" tab. I wanted to open the parameter from "File - Open" Parameter browse menu. When I click on "Open" this message showed up. I opened the "Parameter" tab for showing you the settings (helping you to identify the user error, if any).

Thanks and regards

*

Offline Rongyos

  • 22
    • View Profile
  • Hungary
Re: Benedini Mini problems
« Reply #20 on: September 03, 2019, 12:55:40 PM »
Something is wrong

When I wanted to read parameter from Benedini this message showed up:

Quote
Lásd az üzenet végét ezen párbeszédpanel helyett
az igény szerinti hibakeresés megjelenítéséhez.

************** Kivétel szövege **************
System.ArgumentOutOfRangeException: A(z) „0” érték érvénytelen a következőhöz: „Value”. „Value” értéke csak 'Minimum' és 'Maximum' közötti lehet.
Paraméter neve: Value
   a következő helyen: System.Windows.Forms.NumericUpDown.set_Value(Decimal value)
   a következő helyen: TBS_Flash.Main.UpdateParameterPageValues()
   a következő helyen: TBS_Flash.Main.btnReadParameter_Click(Object sender, EventArgs e)
   a következő helyen: System.Windows.Forms.Control.OnClick(EventArgs e)
   a következő helyen: System.Windows.Forms.Button.OnClick(EventArgs e)
   a következő helyen: System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   a következő helyen: System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   a következő helyen: System.Windows.Forms.Control.WndProc(Message& m)
   a következő helyen: System.Windows.Forms.ButtonBase.WndProc(Message& m)
   a következő helyen: System.Windows.Forms.Button.WndProc(Message& m)
   a következő helyen: System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

[...]  //not relevan (Rongyos)

The attached error message said:

Error does not handle exception in the application. If you push Continue the application will pass th error and try to continue running. In case of push Exit the application exit.
The "0" value is not valid for the field: "Value". "Value" should between "Minimum" and "Maximum". Parameter name: Value

Sorry I translated it fast :(

I would attach the prop and parameter settings but this forum cannot apply this file extention.
 

I discovered the solution myself when I was writing this reply :D I read the PROP1 value in the tbs-flash and realized the neutral is not 121 but was 123. I changed it in the prop menu and and I have movement sound :D (The benedini IS-2 soundset is terrible, but I can say thats a success)
Errormessage.JPG
Benedini Mini problems Errormessage.JPG
Views: 595
solution.JPG
Benedini Mini problems solution.JPG
Views: 603

*

Offline LukeZ

  • 1205
    • View Profile
  • France
Re: Benedini Mini problems
« Reply #21 on: September 03, 2019, 03:27:21 PM »
Hmm... I managed the radio settings 2x, maybe I forgot to upload it to the board :/ I will do it at home again and report the result
It looked like all that happened was you maybe forgot to move the sticks to their extremes when doing the "Save Min/Max" function, but your aux channels seemed correct. I'm sure if you go through it again it will be fixed.

The V4.0 flash is different, I think. There is no upload button on "Diagnostic" tab. I wanted to open the parameter from "File - Open" Parameter browse menu. When I click on "Open" this message showed up. I opened the "Parameter" tab for showing you the settings (helping you to identify the user error, if any).
Ok, I understand. Is there any option in the "File" menu to open a "Prop settings" file?

Either way, it seems Thomas has changed the prop values because 121 was correct for Flash v3 (EDIT - no, the values remain the same for all versions of Flash, continue reading below). I have changed the forum settings so you can now attach a "tbc" file. Now that you have discovered the correct values, are you able to save your prop settings from Flash v4 and post them here?

I have requested a copy of Flash v4 from Thomas but have not yet heard back.
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

*

Offline Rongyos

  • 22
    • View Profile
  • Hungary
Re: Benedini Mini problems
« Reply #22 on: September 04, 2019, 12:18:54 PM »
It looked like all that happened was you maybe forgot to move the sticks to their extremes when doing the "Save Min/Max" function, but your aux channels seemed correct. I'm sure if you go through it again it will be fixed.
Yes, I missed the step when the software is waiting for the min/max values. I set it again and works fine

Either way, it seems Thomas has changed the prop values because 121 was correct for Flash v3. I have changed the forum settings so you can now attach a "tbc" file. Now that you have discovered the correct values, are you able to save your prop settings from Flash v4 and post them here?

I attached the working .tbc   Can you add the .tbp extension too?
KV1_bene_prop_OK.tbc
(0.27 kB ~ Downloads: 205)

*

Offline LukeZ

  • 1205
    • View Profile
  • France
Re: Benedini Mini problems
« Reply #23 on: September 04, 2019, 10:58:40 PM »
Ok, you can now upload ".tbp" files as well, but remember - there is no single parameter file that will work for every user, because people can load their sounds in any order or their Benedini sound file set may have the sounds in a different order. So sharing parameter files is not very useful.

Back to the issue with the prop settings - I have obtained a copy of TBS Flash v4 and spoken with Thomas. No changes have been made to the operation of the Mini when it comes to the prop settings, so the original values should be correct. I have tested Flash v4 with my own Mini and the original prop settings work just fine, and when I read the Prop 1 values in TBS Flash I see neutral at 121 (sometimes flickering to 122). I am going to assume that maybe you have some subtrim active on your throttle channel, this would be very easy to do especially if you are using a transmitter with analog trims. Or possibly it was still an issue with your radio setup where it had not saved the center stick position correctly.

However it is perfectly ok for you to adjust the Prop 1 neutral value as you did, and anyway 123 is still very close to 121. But for the official prop settings files and the documentation I am leaving the numbers as they were before.

The one change that did happen with Flash v4 is that files from earlier versions of Flash won't load, even though the actual values remain the same. I have posted new prop settings files (".tbc") to the Wiki page for every compatible version of Flash and the Mini (he now has a Mini V2 with expanded memory). But as I say, all the values remain the same.

The good news is it sounds like you have everything working now, both with your Benedini and your Taigen card. But let me know if you have any more problems!
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

*

Offline Rongyos

  • 22
    • View Profile
  • Hungary
Re: Benedini Mini problems
« Reply #24 on: September 06, 2019, 01:38:09 AM »
Hi Luke!

You are sure, I modified the trim for the throttle because I made a DIY self-centering stick accessory and it did not fit perfectly.
Few month ago I changed this stuff and forgot to set the trim again. I going to set it when I have time.

Do you know why the .NET framework error message appeared for me? I have Win10 EDU x64. Its missing some correct "value" parameter but I cant find what is this.

Thank you for your support!

*

Offline LukeZ

  • 1205
    • View Profile
  • France
Re: Benedini Mini problems
« Reply #25 on: September 06, 2019, 12:46:30 PM »
Do you know why the .NET framework error message appeared for me? I have Win10 EDU x64. Its missing some correct "value" parameter but I cant find what is this.
I don't know, this is Thomas's program and that error message is not very helpful. It also doesn't really seem to be an error because the program still works. I doubt it has anything to do with your Windows version.

I had a similar message when I was experimenting with Flash v4. If you notice, you can select either the TBS-Mini or the TBS-Mini V2. You have to select the correct one for the device you are using, and then you have to update the firmware on it. Also the paramater files are different for the Mini and V2 even though all the settings are the same. It may be that you accidentally tried using a file from the V2 for the Mini or vice-versa.
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

Re: Benedini Mini problems
« Reply #26 on: January 28, 2022, 01:37:09 AM »
We have a similar problem to this one.

TBS mini V1 the sound files load, and the prop files from the wiki load but the parameters file doesn't load and reports an error. on our mini V2 it works fine.
Firmware is up to date.
Do we have to load the parameters manually on the V1?

Also there are 3 different king tiger files are listed under the TCB what are the differences?

*

Offline kettenpaul

  • 40
    • View Profile
  • Deutschland /Mecklenburg /Vorpommern/kröpelin
Re: Benedini Mini problems
« Reply #27 on: January 28, 2022, 12:16:45 PM »
Hallo
Ich habe auch  Minni und micro bei Banggood gekauft nachdem ich mich von Elmod verabschiedet habe.
Wenn was bei Elmod  (Dark Rider) nicht Funktioniert einschicken und wird wohl nicht mehr zu reparieren sein ist die Antwort.
Dann kaufe ein neues für 230 Euro.
Und minni und DasMikro habe ich erst  später rausgefunden das es kopien  sind und es ist mir völlig egal von wo sie kommen
Sie funktionieren und der Preiß war auch in Ordnung.
Es gibt Das Minni V1 bei Banggood 10ner anschlußleiste im Moment für56,00 Euro
Und der chinese kopiert alles .


Gruß wolfgang

*

Offline LukeZ

  • 1205
    • View Profile
  • France
Re: Benedini Mini problems
« Reply #28 on: January 28, 2022, 02:36:36 PM »
TBS mini V1 the sound files load, and the prop files from the wiki load but the parameters file doesn't load and reports an error. on our mini V2 it works fine.
Firmware is up to date.
Do we have to load the parameters manually on the V1?
Yes typically the user will have to enter the Parameters manually because they can be different for each person depending on which sounds you are using and in which order. However, I understand that after you have set the parameters to your liking you may wish to save a Parameter file (.tbp) for your own use. I have the same experience as you do - if the device is set to TBS Mini V1, TBS Flash will give me an error when I try to load a Parameter file, even if it is one I have just saved a few moments before. When the device is set to TBS Mini V2 then it loads the .tbp file without error.

I don't know why TBS Flash is doing this but only Thomas can fix it.

Also there are 3 different king tiger files are listed under the TCB what are the differences?
I am not sure why there are three King Tiger sound sets. My login to the Benedini downloads page no longer works so I can't see, but I wonder if he had a different set for each of the three devices (Micro, Mini V1 and Mini V2)? But then of course you would expect three sets for each tank. I think you will just have to try them yourself to see what the differences are, if any.

I am sorry I can not be of more help with this issues but I think these questions will need to be addressed to Thomas himself. 
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

Re: Benedini Mini problems
« Reply #29 on: January 31, 2022, 03:09:28 AM »
Thanks Luke, all working as it should now.

I prefer the 2nd sound set but the gun sounds are lacking in all the benedini sounds so custom sound files are next on my hit list.

May try the openpanzer sound if I can get my head around whats needed.

 

bomber-explosion