Registration Notice

Due to increased spam, forum registration must be manually approved by a moderator! Please see this post for instructions.

*

Offline NS-21

  • 53
  • dreamer
    • View Profile
Re: TCB Firmware with Stock Arduino Mega
« Reply #225 on: September 03, 2023, 04:57:34 PM »
Hi,
I have suddenly started having an issue with my Arduino Mega 2560 diy board.
The issue is that if i connect a freshly charged NIMH 7.2v pack or 2cell lipo via the jack plug the board throws a fit by flashing all the lights on in quick time, All the lights, those on the model and board and forward and reverse indicators, the board will not function, the receiver is powered up and lights up but the board is giving the signal of no radio connection yet it is, or low voltage but it is not???
The puzzling part is if i connect a slightly used NIMH pack say around 7.5 volts the board powers up first time every time, even when i connect a 6v NIMH pack it functions correctly, but not with a fully charged pack. It is as if something is limiting the voltage going into the board at a set voltage

Does any one have any ideas how to fix this issue its driving me nuts..thx
Regards.
Sub.

I'm certainly not a direct expert, but there is very little data.

For example:

1. I would like to see a diagram. Have you created your own version based on a respected author's board, or are you following his design?

2. Many interesting points, but so far you have provided little information.



Like mine.

I have created many versions (about 16 software versions and four hardware versions) based on Luke's original product.

I tested the microcircuit, the main power supply was 20 volts. I shared the power, and powered the 2560 DIY version from 16 volts. I have not seen such problems.

P.S. Yes, I've had a lot of fun with this project.

*

Offline Sub

  • 42
    • View Profile
Re: TCB Firmware with Stock Arduino Mega
« Reply #226 on: September 04, 2023, 10:15:13 AM »
Hi,
Thx for your quick reply, to answer a few of your questions,
The board is a stock Arduino mega 2560, nothing i have made, it is flashed with Luke's DIY Arduino firmware, 7.2volts power is supplied to the board via the jack plug utilising the on board 5v volt regulator for running the board only and utilises a separate 5v independant board for positive and negative feeds for the ancillary components, servos, leds etc with a common negative.

I have now managed to identify and isolate the issue, i had an incling what it was and further testing has confirmed it, as i mentioned in my earlier post, it works fine on 7.4volts but not on anything more despite being rated from 5 volts to 12v input
I checked the specs and various youtube testing videos of the AMS 1117 5.0 VOLT regulator chip mounted on the board and it appears that they are equipped with a thermal regulator that shuts the chip down if it gets over voltage or over current, then re sets when cooled ( provided you have not blown the chip off the board )
It would appear that for some reason my regulator chip has become defective and its parameters have gone out of whack and it tripping this failsafe too early.

I had another chip on an Arduino Uno i was not using so removed it and soldered it back onto my Mega board and everthing is now working fine
A pic of the offending regulator chip.
Hope this may be of use if someone else has this issue.
Regards.
Sub

20230904_153750.jpg
Views: 5175
20230904_161221.jpg
TCB Firmware with Stock Arduino Mega 20230904_161221.jpg
Views: 3611

*

Offline LukeZ

  • 1246
    • View Profile
  • France
Re: TCB Firmware with Stock Arduino Mega
« Reply #227 on: September 04, 2023, 01:48:56 PM »
Hi Sub, sorry for the slow reply. I would have guessed the voltage regulator as well, but you discovered it yourself. Good work, and thanks for reporting back.

I remember reading somewhere that some of the Chinese Arduino boards use voltage regulators which have a lower current rating than what they claim in the specifications. At higher currents, this could cause the thermal shutoff that you theorize. And the higher the input voltage that the regulator has to drop to 5 volts, the more current and heat will be created. This might explain why yours worked with a lower voltage battery but not with a higher voltage battery.

In your case it seems like the regulator worked for a long time but slowly began to fail. I guess it was just a poor quality part. I agree, hopefully this information will be useful to others.
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

 

bomber-explosion