Registration Notice

Due to increased spam, forum registration must be manually approved by a moderator! Please see this post for instructions.

*

Offline osika

  • 53
    • View Profile
Update issue
« on: June 03, 2021, 01:42:49 PM »
Hey Luke,

Trying to change some functions and a pop up window shows latest version
needed. I believe I did update it to .93.73 as functions show high and low not a and b
on external outputs a/b. It says latest release when I hit "Get Latest Release" tab.
When I try to flash it (just to try) it says no file found. But the issue is I cannot connect
as pop up window shows device needs update? Also if I hit a question mark on a tab like
sound for let's say mechanical barrel..pop up reads " The collection file 'C:/Program Files etc. do not exist?

Thanks!

Tom

*

Offline osika

  • 53
    • View Profile
Re: Update issue
« Reply #1 on: June 03, 2021, 04:16:03 PM »
A few more notes: When I hit "Get latest release" green bar at bottom says " Release 0.93.73 downloaded"
When I hit flash tab.. pop up reads "File does not exist! Please re-check."

*

Offline LukeZ

  • 1205
    • View Profile
  • France
Re: Update issue
« Reply #2 on: June 03, 2021, 06:37:38 PM »
Hi Osika, this is a strange collection of symptoms, it seems as if your OP Config installation directory was changed or something, since it is not finding the help files or the firmware file you've downloaded. I'm willing to be it was downloaded, just not to the location OP Config is expecting.

I would recommend uninstalling OP Config and then doing a clean install by downloading the program from the Downloads page. Let me know if that helps.
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

*

Offline osika

  • 53
    • View Profile
Re: Update issue
« Reply #3 on: June 03, 2021, 09:45:45 PM »
I uninstalled then reinstalled but same thing. When it connects I can ignore update pop up sometimes and download new functions but it says of 330 one was not installed. (paraphrase) Maybe I can try all of this on a friends computer and see if I can flash latest update from there. Using 3 TCB's.. one opens with port 4/ one with  5 /and one with port 6. But cannot flash .93.73 on any of them. Though
it is odd that it seems I did do flash updates prior because function list says high and low on External outputs A/B?

*

Offline LukeZ

  • 1205
    • View Profile
  • France
Re: Update issue
« Reply #4 on: June 03, 2021, 10:12:16 PM »
You clearly have version 0.93.73 of OP Config, but that does not mean you have version 0.93.73 of the TCB firmware, and this seems to be the problem. If you are able to connect to your TCBs with Snoop, you can see in the Console what version of firmware they are running.

If downloading the firmware from OP Config is not working, you could also manually download the TCB hex file from the Downloads page - right click the "Compiled hex" link in the TCB firmware section and then save it to your desktop or somewhere on your computer. Then in OP Config on the Firmware tab click the "Use your own Hex" button to select this file, and try to flash that.
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

*

Offline osika

  • 53
    • View Profile
Re: Update issue
« Reply #5 on: June 03, 2021, 10:31:21 PM »
Hey Luke that worked..thank you!!!

*

Offline LukeZ

  • 1205
    • View Profile
  • France
Re: Update issue
« Reply #6 on: June 03, 2021, 10:41:36 PM »
Great!
NO SUPPORT THROUGH PM - Read why
Need a forum account? Read here
Open Panzer FAQs

 

bomber-explosion